Threat Level: green Handler on Duty: Johannes Ullrich

SANS ISC: Windows 7 / 2008 R2 Service Pack 1 Problems - SANS Internet Storm Center SANS ISC InfoSec Forums

Watch ISC TV. Great for NOCs, SOCs and Living Rooms:

Sign Up for Free!   Forgot Password?
Log In or Sign Up for Free!
Windows 7 / 2008 R2 Service Pack 1 Problems

I will use this post to collect some of the problems we are hearing about with Windows 7 SP1 and Windows 2008 R2 SP1. Right now, there is no urgent reason to install this service pack and it should be tested first.

A few areas to watch:

- Whitelisting / Blocklisting: Whitelisting software may not have checksums yet to verify all the files that are modified by the service pack. Same for anti-virus: Some anti virus products monitor system files for changes and may sound an alert or block the installation of SP 1

- Firewalls: Third party firewalls may find that some of the low level hooks they use have changed.

- Disk Encryption: In particular full disk encryption that modifies the boot process may find that some of the changes it did are undone by the SP install

- Custom hardware: If you are using drivers other then those that are included in Windows 7 (or 2008 R2), be careful.

Specific examples. Consider them anecdotal but if you run any software mentioned here, or similar software, this list should give you a guide to test.

  • Users with old versions of Microsoft Security Essentials may not be able to install SP1. Upgrade first.
  • Samsung Galaxy S phone drivers may have problems with SP1
  • some users reported very long install times (> 1hr. but not all that unusual for a service pack)
  • Chrome 10 and 11 have issues according to some tweets
  • Word 2003 VBA
  • slower boot times with SP1 then without
  • some reports of download issues due to overloaded servers
  • Lenovo's Thinkvantage System Update may not work (update it before applying the SP)
  • EVGA Precision Utility 2.0.2 (Graphics card stats program liked by gamers)
  • MSI Afterburner
  • some issues with Bitlocker are reported. But no confirmation at this point and it may also be due to entering the wrong password on reboot (you have to reboot a couple times in certain situations)

Link to a technet page with reports of install issues:

If all fails, here a link with an uninstall procedure for SP1:

To temporarily block installation of the service pack:



Johannes B. Ullrich, Ph.D.
SANS Technology Institute

I will be teaching next: Application Security: Securing Web Apps, APIs, and Microservices - SANS Cyber Defence Japan August 2022


4513 Posts
ISC Handler
Feb 24th 2011
I have had two different win7 (x64) machines that I had been unable to install sp1 on. I am installing manually from the (gigantic) x64 download file. I have used this same exact file to update two 2008r2 x64 servers already, so I know that the file is OK. (I have also tried to update both machines via automatic updates, and that just flat out fails, for sp1.)
Has anyone else seen this behaviour? (and/or know how to fix it?) m$ suggests running the 'update readiness tool', but that does nothing to resolve the issue either.
Also, the one machine is fresh out of the box from HP, and has nothing 3rd party on it. I am running the newest MSE on both as well.
sorry, I can't edit posts, screenshot here:
SP1 install on 64-bit Win7 Ultimate failed badly overnight on my Lenovo Thinkpad W700. It's in rebuild mode now. No clue yet what broke.

5 Posts
I've installed it successfully on Windows 7 Professional 32-bit and 64-bit with no issues.

1 Posts
BRAND NEW HP/COMPAQ laptop out of the box WILL NOT load sp1 x64, SAME issue as the previous screenshot. NO AV, NOTHING has been done to this machine other than the initial config that you have to go through to get to windows on a first boot on an OEM machine.
I refuse to believe that I am the only one having this issue, can anyone shed any light on this?!
It borked my Windows XP mode, had to reinstall the VPC.

34 Posts
1. Tried on two new HP Laptops, where Hard disc of Windows shrunk to allow a partition for on-disc back up. No capability to load SP1 per error number as any attempt to partition with other than windows software will eliminate ability of SP1 to read Windows System partition to allow it to load.
2. I think MS have shot themselves in the foot here! Many folk a) dual boot b)alter partitions to allow other back up software to work.
3. Comment is that in Europe this could be construed as misuse of a dominant position and allow even greater fines on MS. Or was it just bad software writing!
1 Posts
I had a successful install of SP1 (Windows 7 Enterprise, 32-bit) on a laptop dual-booted with (and probably partitioned by) Linux. Aside from trouble with the machine overheating during the install, it went smoothly.

1 Posts
I run Checkpoint Full Disk Encryption (FDE) and haven't had any problems.

135 Posts
There's a workaround for problems multiboot and similar here:

There are fixes for other problems on the blog

11 Posts
0x80200053 is the specific error code that I am getting on the machines that are not updating...
I attempted to install it on Windows 7 Ultimate (32-bit) using WSUSOffline 6.8 and started getting boot-time errors.

Status 0xc00000e INFO: The boot selection failed because a required device is inaccessible.

I am restoring from last night's backup before attempting to apply directly using Microsoft Update.

1 Posts
Install was not a problem on 64 bit home premium, but other issues. Although it does not go into sleep mode, when monitors turn off, logitech mouse (USB wired trackball) could not wake it. Pointer still there, but could not move it. Also, when shutting down, shutdown screen stayed forever. Problem fine after reboot until monitor turned off again. I uninstalled SP1 and hope that resolves these issues.
1 Posts
install worked smoothly win 7 pro x64 on lenovo thinkpad x201x. but I can confirm problems using chrome 10. I hat do step back to chrome 9 stable because it won't start at all.
1 Posts
After two repair cycles, SP1 for 64-bit Win7 Ultimate still fails on my Thinkpad W700 with an "Error C000009A applying update operation 135357 of 355497 (\Registry\...)". Many reports of this same error are popping up support boards. All appear to be 64-bit specific.

5 Posts
C000009A seems to be related to x64 systems with various language packs beeing installed on the system. See and for example.
Looks like it would be a good idea, to uninstall any Language Packs PRIOR to installing SP1 at the moment.
Chrome devbuild began working after one launch with admin rights.

6 Posts
I updated 2 WEindopws 7 computers without issue. One a 64-bit and one a 32-bit. Two other 64-bit Windows 7 installations, interestingly, have not been able to get SP1. Is this to manage bandwidth or is it because of the issues?

63 Posts
We have seen no other problems besides slow shut down after SP1 installation. As well as "Very" slow reboot after SP1 install.
My machine installed both SP1 for English and SP1 for Spanish also.
Intel I5 w/8Gb two(1.5 Tb drives)
1 Posts

Sign Up for Free or Log In to start participating in the conversation!