Svchost, Microsoft Updates, and 99% CPU Usage

Published: 2007-04-12
Last Updated: 2007-04-13 16:58:04 UTC
by Joel Esler (Version: 3)
0 comment(s)
Update (Kyle Haugsness):  I think we've received enough email on this...  Looks like lots of folks are seeing this in small percentages going back several months (on average it seems like a small handful of machines at any particular site).  Some people are having luck with the 927891 hotfix below.  Other people have had luck just waiting 30 minutes, rebooting 5 times, or going backwards from Microsoft Update to Windows Update.  Your mileage may vary.  (Note that due to the large volume of e-mail we received on this, you might not get a response from us but your message has been read and your contribution is appreciated.)

We received a couple emails today talking about the latest Microsoft Updates and the svchost service taking up 99% of CPU Utilization after applying them.

Is this isolated to a couple people, or is this more widespread?  Then, if it is widespread, and you fixed it, how did you do it?  Share your insight!

One of the other handlers pointed me to this KB article: http://support.microsoft.com/kb/916089/.  Take a look at that if you are affected.

(Thank you Noah, and other readers who wished not to be named for your submission!)

Alot of people wrote in with a patch that takes precedence over the one above.  http://support.microsoft.com/kb/927891/

(Not being a Microsoft guy myself....)

Joel Esler
Handler o' the Day
http://handlers.sans.org/jesler
Keywords:
0 comment(s)
Diary Archives